Jan 25, 2010 at 7:05 PM

I know if may cause people grief, but I would like to see InvokePropertyChanged renamed to RaisePropertyChanged.

Jan 25, 2010 at 7:59 PM

why would you want to make the change?  I'm not tied to one or the other other then InvokePropertyChanged is more inline with my own naming approach but only a little... :)

Jan 26, 2010 at 2:37 AM

Well, as I tweeted today, we already have too many MVVM frameworks and that is an obstacle that doesn't have a good answer yet, but one problem is that everyone is using a different method call for PropertyChanged which is helping to confuse people. The answers I have gotten so far are that of the three popular choices (OnPropertyChanged, RaisePropertyChanged, and InvokePropertyChanged) Raise is the most correct and Invoke is just wrong. I think the objection with Invoke is that it is a specific meaning that doesn't involve raising an event.

Jan 26, 2010 at 5:22 PM

we certainly have to many MVVM frameworks, thats why we did thisone... :)  so why is RAise the most correct and Invoke just wrong?  To me 'Invoke' implies firing an interface from my old COM days so it seems the most correct to me in its meaning.?  OnPropertyChanged gives me VB flash backs so that makes that one wrong and Raise I guess I understand as raising an event which we are not really doing?

Jan 26, 2010 at 8:30 PM

But, raising an event is exactly what we are doing. We are raising the PropertyChanged event. We aren't invoking an interface, we are raising an event.

Jan 26, 2010 at 9:46 PM

Yes, but I wanted to hear that argument articulated first, with which you did so I'll change it.  need to post an updated version anyway.